Bug #20853

syslog for getFileName() returns empty String in some cases (useless log-info)

Added by David Bruchmann over 10 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-08-08
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

the variable $newFile is only filled in some cases (i.e. when the correspondending extension isn't loaded) and is useless for syslog or admPanel when it's empty.

concerned lines:

if (!strcmp(substr($file,0,4),'EXT:')) {
$newFile='';
list($extKey,$script)=explode('/',substr($file,4),2);
if ($extKey && t3lib_extMgm::isLoaded($extKey)) {
$extPath=t3lib_extMgm::extPath($extKey);
$newFile=substr($extPath,strlen(PATH_site)).$script;
}
if (!@is_file(PATH_site.$newFile)) {
if ($this->tt_track) $GLOBALS['TT']->setTSlogMessage('Extension media file "'.$newFile.'" was not found!',3);
return;
} else $file=$newFile;
}

Instead of
if ($this->tt_track) $GLOBALS['TT']->setTSlogMessage('Extension media file "'.$newFile.'" was not found!',3);
I propose to write
if ($this->tt_track) $GLOBALS['TT']->setTSlogMessage('Extension media file "'.$newFile.'" ('.$fileFromSetup.') was not found!',3);
or simply
if ($this->tt_track) $GLOBALS['TT']->setTSlogMessage('Extension media file "'.$fileFromSetup.'" was not found!',3);

There is only one line to change
(issue imported from #M11673)

History

#1 Updated by David Bruchmann over 10 years ago

sorry, the first sentence of description has to be:
the variable $newFile is only filled in some cases (i.e. when the correspondending extension is loaded) and is useless for syslog or admPanel when it's empty.

so the variable $newFile IS NOT filled when an Extension IS NOT LOADED

#2 Updated by Alexander Opitz almost 7 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • TYPO3 Version set to 4.3

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#3 Updated by Alexander Opitz over 6 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF