Bug #20896

rtehtmlarea crashes chrome-browser when utf-8 letters are used

Added by David Bruchmann about 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2009-08-18
Due date:
% Done:

0%

TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

rtehtmlarea crashes chrome-browser when utf-8 letters are used.
Opening a record with arabic text (mixed with western letters) in BE crashes the BE-Window as well as the FE-Window inside Browser.

Versions:
Browser: 3.0.195.6
TYPO3: 4.2.8
rtehtmlarea: 1.7.11
OS: WinXP
Php: 5.2.10
mySQL: 5.0.51a

Reproducibility: On my System: always

Used Text:

Newsbeitrag Text äöü ÄÖÜ ß ???? ??????? ?? Windows NT Server 3.51 ? Workstation 3.51 ? ??? ????? ??????? (FAQ) ??? ????? ? Windows NT 3.51 ? ?? ????? ? ???? ?? ? ?? ?? ?? ?????. ? ????? ?? ????? ?????? ?????: " ?? ??? ?????..
(issue imported from #M11736)

History

#1 Updated by David Bruchmann about 11 years ago

Take some text from here - I used the Text from inside meta-description prepended with "Newsbeitrag Text äöü ÄÖÜ ß ":

http://support.microsoft.com/kb/298459/ar

#3 Updated by David Bruchmann about 11 years ago

Doesn't occur in normal Text-Records but in tt_news-records

#4 Updated by Stanislas Rolland about 11 years ago

I was able to produce a tt_content record that reproduces a similar issue. If the record opens on the tab containing the RTE-enabled field, Google Chrome 4.0.203.2 craches. If the record opens on another tab, switching to the tab containing the field allows to view the record without any problem. The problem does not appear in Safari 4.0.3. Nor does the problem appear with TYPO3 trunk (4.3)... Very hard to understand what is going on at the moment the browser crashes.

#5 Updated by Stanislas Rolland over 10 years ago

Perhaps the issue was fixed in the browser. I am unable to reproduce this issue in Google Chrome 6.0.422.0 dev.

Also available in: Atom PDF