Bug #21110

PHP-5.3 warning about missing references with some extensions

Added by Stefan Froemken over 11 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2009-09-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

sr_feuser_register works with a reference in main function:
function main($content, &$conf)
but in Trunc-Version of TYPO3-Core 4.3-dev appears an error in FE, when make a reference in main-function.

I created a bugreport for sr_feuser_register:
http://bugs.typo3.org/view.php?id=11999
but the programmer means, this problem has to be solved in Core.

PHP Version 5.3.0

patch should go in all supported branches
(issue imported from #M12022)


Files

12022.diff (756 Bytes) 12022.diff Administrator Admin, 2009-11-06 13:49
#1

Updated by Stefan Froemken over 11 years ago

I'll never learn it to change category first. Is there somebody who can move this entry to core-list?

#2

Updated by Rupert Germann over 11 years ago

the attached patch solves the problem for me.

tested with PHP 5.3 (win) and 5.2 (linux) with an extension with reference set or not set on $conf

#3

Updated by Rupert Germann over 11 years ago

RFC is dropped,
because the described problem is not a problem of the TYPO3 core, it's a changed behaviour in PHP 5.3.
If extensions are not compatible to PHP 5.3 this can not be fixed in the core.

see discussion in core-list

Also available in: Atom PDF