Bug #21187

"Create link" button doesn't become clickable when using keyboard to select text in Safari/Chrome

Added by Richard about 12 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2009-10-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

To reproduce the bug:
  • Edit text in any content element using the htmlarea RTE
  • Write a sentence, the select some words only using the keyboard (cursor keys and Shift to select)
Result:
  • The "create link" button doesn't become enabled although text is selected
Expected result:
  • The "create link" button shall become clickable
Workaround:
  • Use the mouse to select the text

Chromium 4.0.221.3 (Ubuntu build 27948)
Typo3 4.2.8
(issue imported from #M12115)


Files

rtehtmlarea_bugfix_12115_trunk.patch (666 Bytes) rtehtmlarea_bugfix_12115_trunk.patch Administrator Admin, 2009-11-10 06:33
rtehtmlarea_bugfix_12115_typo3_4-2.patch (666 Bytes) rtehtmlarea_bugfix_12115_typo3_4-2.patch Administrator Admin, 2009-11-10 06:34
#1

Updated by Stanislas Rolland about 12 years ago

The problem appears in Safari or any browser based on Apple WebKit.

#2

Updated by Stanislas Rolland about 12 years ago

Committed to SVN TYPO3core trunk (revision 6397) and branch TYPO3_4-2 (revision 6398).

#3

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF