Bug #21339

"Generate random key" button doesn't work

Added by Tymoteusz Motylewski almost 10 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-10-22
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In Typo3 4.2.9 installation tool -> "Basic Configuration" there is a button "Generate random key" used to generate encryption key. There is no action after clicking this button. I tested it in both Firefox 3.5 and Google Chrome 3.0

(issue imported from #M12313)

History

#1 Updated by Chris topher almost 10 years ago

I checked this with Firefox 3.5.3 in TYPO3 4.3.beta2 (= current trunk) and it works.

If it works in other browser, you must use a strange setting.
Do you for example have JavaScript allowed for this domain?

#2 Updated by Tymoteusz Motylewski almost 10 years ago

I checked this in IE 8 and in FF on another computer, and it doesn't work. JavaScript and cookies are enabled (BE is working correctly). I set the breakpoint in IE developer Toolbar in install.js. It turned out that the function EncryptionKey.load() is fired after clicking on "Generate encription key" button, but the edit box is still empty.

#3 Updated by Steffen Kamper almost 10 years ago

did you checked it in 4.2.10? Imho i fixed it there.

#4 Updated by Tymoteusz Motylewski almost 10 years ago

I updated typo to 4.2.10 but it didn't resolve the problem. I made an installation on my local computer (windows) and it is working there. So it must be something hosting-related, but I still don't know what.

#5 Updated by Alexander Opitz over 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • TYPO3 Version set to 4.2

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#6 Updated by Alexander Opitz about 6 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF