Bug #21351

Plugins may not be loaded for multiple RTEs

Added by Ralf Hettinger about 12 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2009-10-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

htmlarea's plugins may not be loaded and thus not be available although configured for follow up RTEs, when more than one RTE is rendered.

Reason: The to be loaded plugins are evaluated based only on the very first htmlarea being generated.

Example: have two RTE fields field_1 and field_2 of table some_table shown within the same TCEform with the following configuration:
RTE.config.some_table {
field_1.showButtons = undo,redo,copy,cut,paste
field_2.showButtons = link,undo,redo,copy,cut,paste
}
Result: field_2 will have no link button, since plugin TYPO3Link is never loaded.

Solution: Load plugins for all htmlareas.

(issue imported from #M12331)


Files


Related issues

Related to TYPO3 Core - Bug #19477: RTE does not work in IRRE subelementsClosedStanislas Rolland2008-10-17

Actions
#1

Updated by Ralf Hettinger about 12 years ago

Version 2 loads htmlarea's plugins for all RTE fields just after all of them were rendered by t3lib_TCEforms.
Avoids loading the same JS Plugins multiple times.

#2

Updated by Zach Davis about 12 years ago

I noticed this same bug on Friday last week. I spent a good couple of hours trying to sort through it, and found the problem to be exactly as Ralf describes it.

#3

Updated by Stanislas Rolland about 12 years ago

I think that this is a regression that was introduced by trunk revision 4556 and TYPO3_4-2 branch revision 4670.

I think the first patch is sufficient and will not load the same plugins multiple times.

The RTE may also be used multiple times in a frontend form.

#4

Updated by Stanislas Rolland about 12 years ago

Patch version 2 committed to SVN TYPO3core trunk (revision 6313) and branch TYPO3_4-2 (revision 6314).

#5

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF