Bug #21700

Save the previous selected type of login in a cookie

Added by Sebastian Michaelsen almost 10 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2009-11-26
Due date:
% Done:

0%

TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If a user likes to login via OpenID, he has to click "Switch to OpenID" first, to get the the right login form. He needs to do this every time he wants to log in, which is avoidable pain.
My suggestion is to save the user's choice in a cookie.

Steffen Kamper pointed out that nobody needs to click on "Switch to OpenID", because you can also just paste your OpenID Identifier to the username field.
This might be right, but then the divisiion between conventional und openid login does not make any sense.
(issue imported from #M12779)

logintype-cookie.diff View (1.76 KB) Administrator Admin, 2009-11-26 16:42

History

#1 Updated by Benni Mack almost 10 years ago

commited v5 to trunk (rev. 6731)
commited v5 to TYPO3_4-3 (rev. 6732)

#2 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF