Bug #21864

overriden user settings are not visible to the user

Added by Georg Ringer about 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
Start date:
2009-12-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

It is possible to override settings in the user settings with TS. Currently this is not visible to the user because the fields are not locked. Result: A user will try to change the settings but it is not possible because not allowed.

To reproduce add those lines to your user tsconfig:
--------
setup.default.edit_docModuleUpload = 1
setup.override.edit_docModuleUpload = 1

setup.default.resizeTextareas_MaxHeight= 111
setup.override.resizeTextareas_MaxHeight= 310
---------

and go to the user settings > tab "edit & advanced functions". ┬┤Change the text in the input field "maximal height of resizeable textareas" and save it. Changes won't be saved.

Apply patch and take a look at the settings again. They are now rendered with the attribute disabled="disabled"

(issue imported from #M13059)


Files

13059-disabled-user-settings.patch (563 Bytes) 13059-disabled-user-settings.patch Administrator Admin, 2009-12-18 08:07
13059-disabled-user-settings.gif (14.6 KB) 13059-disabled-user-settings.gif Administrator Admin, 2009-12-18 08:07
#1

Updated by Benni Mack about 11 years ago

Commited your patch to trunk (rev. 6690)
Commited your patch to TYPO3_4-3 (rev. 6691)

Also available in: Atom PDF