Bug #22206

Change password don't working correctly

Added by Dmitry almost 12 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
felogin
Target version:
-
Start date:
2010-02-27
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

when you send new password -pass in update in DB,
but in FE show error: "Click on a link is incorrect. Repeat the procedure for password reminder."

I think this is due to the fact that not work out correctly
if (!$compareHash || !$compareHash1 || $compareHash0 < time() || $hash0 != $compareHash0 || md5($hash1) != $compareHash1) {

becouse $compareHash is empty

(issue imported from #M13691)

#1

Updated by Sebastian Steinmetz about 11 years ago

same problem here. any news about that?

#3

Updated by Alexander Opitz over 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • TYPO3 Version set to 4.3

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#4

Updated by Alexander Opitz about 8 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF