Bug #22301

stdWrap-property spaceAfter works not correctly

Added by Stefan Froemken about 11 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-03-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If I work with spaceBefore everything works like expected:

<img src="clear.gif"><br />My text

"My text" ist in the next row.

But when I use spaceAfter:

1 = TEXT
1.value = Padding with clear.gif<br />
1.spaceAfter = 20
2 = TEXT
2.value = Hello

then I got:

My text<img src="clear.gif"><br />

that's wrong. I think it should be

My text<br /><img src="clear.gif">

In row 6605 of class.tslib_content.php I found the mistake. <br /> is at the end of the line instead of front.
(issue imported from #M13866)

#1

Updated by Chris topher almost 11 years ago

Since you already have the fix ready, please make a patch file out of it and send it to Core List!

#2

Updated by Susanne Moog over 9 years ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (0)

IIRC spaceAfter is now done without the clear.gif isn't it? I'm closing this one, please reopen it, if it's still a problem.

Also available in: Atom PDF