Bug #22306

Backend Module produces php errors

Added by Lina Wolf about 9 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-03-22
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In file index.php in
typo3_src-4.2.12/typo3/sysext/indexed_search/mod

should be testet if its really an array at line 439:
function formatCHash($arr) {
if(is_array($arr)) {
reset($arr);
$list=array();
while(list($k,$v)=each($arr)) {
$list[]=$k."=".$v;
}
return implode("<BR>",$list);
}
}

(issue imported from #M13876)

13876.diff View (2.56 KB) Administrator Admin, 2010-03-22 14:27


Related issues

Duplicated by TYPO3 Core - Bug #18859: Admin Tools -> Indexing -> List: Typo3 Pages Bug Closed 2008-05-27
Duplicated by TYPO3 Core - Bug #14985: Backend module List: TYPO3 Pages dumps PHP warnings, no array found Closed 2005-09-21

History

#1 Updated by Dmitry Dulepov about 9 years ago

Note for coredevs: do NOT submit this patch to the core list. See issue #13885.

#2 Updated by Alexander Opitz about 6 years ago

  • Status changed from Accepted to Needs Feedback
  • Target version deleted (0)
  • TYPO3 Version set to 4.2

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#3 Updated by Lina Wolf about 6 years ago

I haven't run across this error in 4.5. Can be closed

#4 Updated by Alexander Opitz about 6 years ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF