Bug #22316

"View" Function ignores "Show Hidden Pages" option, shows all hidden pages

Added by Tobias Lohmann about 9 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2010-03-23
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

There are two problems with the "View"-Function:

1. the "Show Hidden Pages" option ignored in "Web --> View" mode, always shows all hidden pages in menus.
2. disabled "Show Hidden Pages" option when previewing a hidden page show all hidden pages in menus.

Given the following example tree:
- page 1
- page 2 (hidden)
- page 3 (hidden)
- page 4

The "View"-Function when called from the Backend (Web --> View) always shows hidden pages, completely ignoring the "Show Hidden Pages" option. Pages 1, 2, 3, 4 are shown in menus.

When called from the Page-Tree context menu the "View"-Function shows all hidden pages when previewing a hidden page, completely ignoring the "Show Hidden Pages" option. Pages 1, 2, 3, 4 are shown in menus.

When called from the Page-Tree context menu the "View"-Function shows the hidden pages depending on the "Show Hidden Pages" option when viewing a non-hidden page. Pages 1, 4 are shown in menus.
(issue imported from #M13894)


Related issues

Duplicates TYPO3 Core - Bug #20335: Hidden Content Elements are displayed in the Module "View Page" Closed 2009-04-22

History

#1 Updated by Chris topher about 9 years ago

Hi Tobias,

thanks for your note!
This is a duplicate of #20335.
In that issue Niels Fröhling provided a patch.
Please test and tell us, if this solves the problem...

Christopher

#2 Updated by Tobias Lohmann about 9 years ago

Christopher, thanks for the hint, fixes my problem. Could somebody mark this as duplicate? Or can I?

#3 Updated by Benni Mack 8 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF