Bug #22321

typoLink() always creates absolute links when using more than one domain records

Added by Irene Höppner about 11 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Communication
Target version:
-
Start date:
2010-03-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

... and using another domain than the first in the list of domain records
... and using config.typolinkCheckRootline = 1

That means, if you have more than one domain records in one page like
blue.my-domain.com
green.my-domain.com

and you call the page with "http://green.my-domain.com", all links will be generated as absolute links with the domain blue.my-domain.com:

href="http://blue.my-domain.com/index.php?id=45"

instead of

href="index.php?id=45"

That's a major problem, if you use different domains or sub-domains for a different behaviour of the website, like different colors, different languages, local testing, .... You'll never stay in the domain you called, when clicking just on one link...

This bug is related to #19149, because I think resolving that bug introduced this one :-).

Patch is attached, but did only a quick-check with nested domains.
(issue imported from #M13903)


Files

class.tslib_content.patch (2.68 KB) class.tslib_content.patch Administrator Admin, 2010-03-24 11:31
13903_v2.patch (2.78 KB) 13903_v2.patch Administrator Admin, 2010-03-27 20:44

Related issues

Related to TYPO3 Core - Bug #19149: Inter domain linking with typolinkEnableLinksAcrossDomains does not work for domain record on root pageClosedTobias Liebig2008-07-25

Actions
#1

Updated by Tobias Liebig about 11 years ago

commited in r7718

#2

Updated by Christian Ludwig over 6 years ago

In TYPO3 v6.2.x (current is v6.2.6), this problem exists again. Maybe the introduction of the domain cache function lead to this behaviour?

#3

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF