Bug #22489

Add caption to altText for images

Added by Rik Willems over 9 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-04-20
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Currently you are able to set a caption, alternative text and title text to and image (and its link). Now I think this is often the same. Would it be nice to add the snippet below?

tt_content.image.20.1.altText {
ifEmpty < tt_content.image.20.caption.1
}

This will add the caption text to the altText if it altText is empty. Nice for usability and SEO.

What do you think?

Greets, Rik

(issue imported from #M14157)

History

#1 Updated by Alexander Opitz over 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • TYPO3 Version set to 4.3

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#2 Updated by Alexander Opitz almost 6 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF