Bug #22607

htmlArea RTE: justify after CTRL+A not working in Firefox

Added by bobo no-lastname-given over 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-05-07
Due date:
% Done:

0%

TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

FF3.6.3
typo3 4.2.8
RTE 1.7.11

In rte edit area. If I use "ctrl+A" to select all words and click the button "align left , right , center" , it's not working.

It works ok in IE.
(issue imported from #M14333)

bug1.jpg View (74.9 KB) Administrator Admin, 2010-05-07 14:48

rtehtmlarea_bugfix_14333_trunk.patch View (3.2 KB) Administrator Admin, 2010-05-25 09:15

rtehtmlarea_bugfix_14333_typo3_4-3.patch View (2.71 KB) Administrator Admin, 2010-05-25 09:15

History

#1 Updated by bobo no-lastname-given over 8 years ago

Anyone here ?

#2 Updated by Chris topher over 8 years ago

I just checked that with Firefox with TYPO3 4.3.3 and with current trunk. The behaviour is the same:
I have a text consisting of several p tags in a row, each with some text in it.
Ctrl+A marks the text correctly.

Rightclicking and using e.g. "Justify Right" displays the text in the RTE justified right, but only if the p tag did not have a special class for the alignment added to it before. Any paragraph, which had a class added to the p tag before (e.g. centered), is still displayed as before.

Also, when I toggle to view the HTML source, I see, that the classes which should have been added in the step above were not added to the p tags. None of them is there; instead the old classes are still present.

In the FE the text comes up without the classes which should have been added (but still with the old classes). = same as the HTML source I see when toggling the view in the RTE.

Additional info:
Ir does not matter if I use special classes to align the text. E.g. in page TSconfig:
RTE.default.buttons.left.useClass = linksbuendig
and so on for the others.
The problem is also there, if I do not set such properties.

It works correctly, if I don't mark any text but position the cursor inside one p tag and then add an alignment: It is added to the p tag correctly.

@ huangbo: That is what your bug report already should have looked like.

#3 Updated by bobo no-lastname-given about 8 years ago

@Christopher: Your test is right. If I use "RTE.default.buttons.left.useClass = linksbuendig". The class changed right when I position the cursor inside one p tag. But it's also not work after "Ctrl+A", the class is not changed. How to solve?

ps: It works ok in IE if I use "Ctrl+A".

#4 Updated by Stanislas Rolland about 8 years ago

The attached patches fix the issue in trunk and TYPO3 4.3 branch.

#5 Updated by Stanislas Rolland about 8 years ago

Committed to SVN TYPO3core trunk (revision 7671) and branch TYPO3_4-3 (revision (7672).

Also available in: Atom PDF