Bug #22691

t3lib_error interfaces

Added by Peter Russ about 11 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-05-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

the CORE definition for t3lib_error_t3lib_error_ExceptionHandlerInterface and t3lib_error_ErrorHandlerInterface BOTH provides constructors. By doing this, we can not define ONE class implementing both interfaces nor could we make use of a singleton as these constructors has to be public

(issue imported from #M14448)


Files

patch.diff (531 Bytes) patch.diff Administrator Admin, 2010-05-20 22:01
patch-4.3.diff (3.63 KB) patch-4.3.diff Administrator Admin, 2010-05-20 23:03
#1

Updated by Peter Russ about 11 years ago

Patch for TYPO3 4.3 branch attached

#2

Updated by Benni Mack about 11 years ago

Care to send this issue to the core list?

#3

Updated by Peter Russ about 11 years ago

Could you take care for that as I don't have access to TYPO3 NGs or mailinglists from here :-(

#4

Updated by Alexander Opitz about 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • TYPO3 Version set to 4.4

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#5

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF