Bug #22770

[No Title] shown when editing a record on root level

Added by Soren Malling over 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-05-31
Due date:
% Done:

0%

TYPO3 Version:
4.4
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

For records on root level the title of the record is not shown, when I edit the record.

E.g. the page title isn't shown, when editing page properties of the root page. (Have a look at attached screenshot.)

The field for pagetitle is filled and is shown in the pagetree.
The title is also displayed correctly, when the record I edit is not on root level.

(issue imported from #M14545)

page-properties-no-title.png View (38.1 KB) Administrator Admin, 2010-05-31 07:07

14545.diff View (770 Bytes) Administrator Admin, 2010-05-31 15:04

14545_v2.diff View (1.87 KB) Administrator Admin, 2010-06-01 18:53

14545_v3.diff View (3.19 KB) Administrator Admin, 2010-06-07 13:12

14545_v4.diff View (3.76 KB) Administrator Admin, 2010-06-07 14:06

14545_v5.diff View (4.61 KB) Administrator Admin, 2010-06-09 14:06

14545_v6.diff View (4.16 KB) Administrator Admin, 2010-06-09 14:09

14545_v7.diff View (4.09 KB) Administrator Admin, 2010-06-14 01:28


Related issues

Related to TYPO3 Core - Bug #22783: There is a [No title] Closed 2010-06-01

History

#1 Updated by Reinhard Führicht over 9 years ago

What should this headline show anyway?
I found out the following until now:

- Shows title of the page if creating, editing records (e.g. tt_content)
- Shows title of the parent page if creating a new page
- Should show page title of the current page if editing a page.

Does this even make sense?
If yes, the problem you described should be easy to fix. See attached patch.
It may not be the best solution, but at least it fixes the problem.

#2 Updated by Chris topher over 9 years ago

The same error occurs when editing a BE user.

Can you have a look at that, too?

#3 Updated by Soren Malling over 9 years ago

I can confirm that the attached bug fixes the issue with "Page Properties"

And I can confirm that the same issue is present when editing a be_user

#4 Updated by Reinhard Führicht over 9 years ago

It happens when editing a be_user, be_group, basically anything on the root page (PID:0).

When editing a record, the title of the parent page is shown as the headline. When editing a record on root level, there is no title, because a parent "page" doesn't exist. But which headline to display in that case?

In my opinion, it would be cool to display the title of the currently edited record. By title meaning the label field set in TCA. When creating a new record/page the headline could just say "New page/content/news/whatever". After saving, the entered title could be shown.

#5 Updated by Chris topher over 9 years ago

When creating a new record/page the headline could just say "New page/content/news/whatever". After saving, the entered title could be shown.

Sounds good! Go ahead!

#6 Updated by Reinhard Führicht over 9 years ago

Version 2 added.

When creating a new record, the label will be: Create new [tablename]
When editing a record it will be: Edit [recordtitle]

Please test yourself and see if it works. I am quite in a hurry right now, so I hope I didn't make any mistake in the code.

#7 Updated by Jo Hasenau over 9 years ago

Anything else would be just confusing - I tested it with the current trunk and the title said "Root" while I was editing a page on the next level - so Reinhard's proposal seems to be only useful way to fix this misleading behaviour.

#8 Updated by Reinhard Führicht over 9 years ago

Thanks for the feedback. I will give it a try and post it on the core list.
As I see this as a bug, I hope this gets fixed for 4.4.

#9 Updated by Reinhard Führicht over 9 years ago

version 5 contained changes not belonging to this issue. Please ignore v5 and use v6 instead.

#10 Updated by Steffen Kamper over 9 years ago

Committed to trunk rev 7911

Also available in: Atom PDF