Bug #23371

Provide a reason for logDeprecatedTypoScript()

Added by Steffen Gebert almost 11 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-08-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Currently there's no way to give an explanation, when logging usage of a deprecated TypoScript object/property, because it's implemented the following way:

function logDeprecatedTyposcript($msg) {
  $GLOBALS['TT']->setTSlogMessage($msg . ' is deprecated.', 2);
  t3lib_div::deprecationLog('TypoScript ' . $msg);
}

Because of one time, some text is appended to $msg and one time text is prepended, all the logged entries would make no sense, if you want to provide useful hints.

(issue imported from #M15454)


Files

15454.diff (1.11 KB) 15454.diff Administrator Admin, 2010-08-13 21:18

Related issues

Related to TYPO3 Core - Bug #22162: Deprecation log for IMAGE.alttext does not workClosedSteffen Gebert2010-02-23

Actions
#1

Updated by Steffen Gebert almost 11 years ago

Committed to trunk rev. 8658

#2

Updated by Susanne Moog about 10 years ago

  • Target version deleted (4.5.0)

Also available in: Atom PDF