Bug #23478

Extension tables is messing up on New Record screen

Added by Vladimir Podkovanov about 9 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend User Interface
Target version:
-
Start date:
2010-08-30
Due date:
% Done:

100%

TYPO3 Version:
4.4
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Extension tables is messing up (tables being shown in wrong extensions) on New Record screen in case if table title defined as plain string and not as LLL label

It is because script tries to extract extension name from table LLL title, and if no extension name there (not LLL label) then extension title from previous table used (wrongly)

(issue imported from #M15591)

bug_15591.diff View (1.19 KB) Administrator Admin, 2010-08-30 01:44

Associated revisions

Revision 5132dcdd (diff)
Added by Nicole Cordes over 5 years ago

[BUGFIX] Support for static table titles in new record wizard

With a static table name the extension key is not updated which sets a
wrong table title for the extension before. This patch resolves table
title from configuration with a fallback to table name part and sets
group name and extension key. This helps to prevent any conflict between
different extensions.

Resolves: #23478
Releases: 6.2
Change-Id: I5f33b0a9ab616256f0b328a6d7c793677213531b
Reviewed-on: https://review.typo3.org/28510
Reviewed-by: Vladimir Podkovanov
Reviewed-by: Wouter Wolters
Reviewed-by: Stefan Neufeind
Tested-by: Stefan Neufeind

History

#1 Updated by Alexander Opitz about 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (4.5 or 6.1)?

#2 Updated by Vladimir Podkovanov almost 6 years ago

Hi,

yes, it does. In 4.5 and 6.1 also.

#3 Updated by Alexander Opitz almost 6 years ago

  • Category set to Backend User Interface
  • Status changed from Needs Feedback to New

#4 Updated by Nicole Cordes over 5 years ago

  • Status changed from New to Accepted
  • Assignee set to Nicole Cordes

#5 Updated by Gerrit Code Review over 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28510

#6 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28510

#7 Updated by Vladimir Podkovanov over 5 years ago

On Patch Set 2, shouldn't be made same change ($_EXTKEY = $nameParts1) in previous else-branch too? Please see original patch in the bug tracker.

If there are several tables with label starting with 'LLL:EXT:' but with empty ext key, it seems that these tables would be messed up too, because of same key (empty string) in $this->tRows.

#8 Updated by Gerrit Code Review over 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28510

#9 Updated by Nicole Cordes over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#10 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF