Bug #23496

t3lib_div::generateRandomBytes() is bad and buggy

Added by Stefan Froemken over 10 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-09-03
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I just try to install the new indroduction version of TYPO3 on my server. On step two I get following warning:

Fatal error: mcrypt_create_iv(): Could not gather sufficient random data in C:\Programme\Apache Software Foundation\Apache2.2\htdocs\introductionpackage-4.4.2\t3lib\class.t3lib_div.php on line 1597

The dropdown-box for "Driver" is empty.

I'm using PHP 5.3.3

I found a page where Marcus Krause and Helmut Hummel have already tried to fix that problem:

http://github.com/typo3/typo3v4core/commit/00ce0fe45aa46b62e8aa499912c9e36483185737

But on this site you can read, that the code was not perfect:

http://bugs.php.net/bug.php?id=52523

Have a look at following entry: [2010-08-03 16:11 UTC]
(issue imported from #M15629)


Related issues

Is duplicate of TYPO3 Core - Bug #23355: Speed up / restructure of random byte generator to address e.g. WIN OS specificsClosed2010-08-05

Actions
#1

Updated by Stefan Froemken over 10 years ago

I get the error only when I have restarted my Apacheserver. When I press F5 in the webbrowser (same page) the warning is gone. After restarting Apache I get the same warning again.

#2

Updated by Stefan Froemken over 10 years ago

Maybe this is an important note.:
I work on a windows xp machine with Apache, PHP, MySQL and OpenSSL. NOT Linux and NOT a WAMP-Server based on apachefriends.

#3

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF