Bug #23816

Wrong link generated with "Always prepend this domain in links"

Added by Michael Birchler about 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
felogin
Target version:
-
Start date:
2010-10-21
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If "Always prepend this domain in links" in sys_domain is checked or a extension such as https_enforcer is used typolink generates absolute links.

tx_felogin_pi1::generateAndSendHash doesn't respect this and generates faulty links eg:
instead https://www.domain.ch/de/login/?tx_felogin_pi1%5Buser%5D=4&tx_felogin_pi1%5Bforgothash%5D=1287704628%7Cf642e97d25908a1c2e2231a5a4d75ba6 the link looks like: https://www.domain.ch/https://www.domain.ch/de/login/?tx_felogin_pi1%5Buser%5D=4&tx_felogin_pi1%5Bforgothash%5D=1287704628%7Cf642e97d25908a1c2e2231a5a4d75ba6

(issue imported from #M16097)

class.tx_felogin_pi1.diff View (1.24 KB) Administrator Admin, 2010-10-21 14:06

class.tx_felogin_pi1_V2.diff View (1.21 KB) Administrator Admin, 2010-10-21 14:18

History

#1 Updated by Michael Birchler over 8 years ago

  • Target version deleted (0)
  • % Done changed from 0 to 100

Issue is obsolete. Fixed in 4.5.5.

#2 Updated by Susanne Moog over 8 years ago

  • Status changed from New to Closed
  • TYPO3 Version set to 4.5

Also available in: Atom PDF