Bug #23840

config example for memcached in t3lib/config_default.php breaks TYPO3 BE + FE

Added by Georg K├╝hnberger almost 9 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Category:
Caching
Target version:
-
Start date:
2010-10-25
Due date:
% Done:

0%

TYPO3 Version:
4.4
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Used Core-Version:
TYPO3 4.4.4 (and 4.3)

Issue:
t3lib/config_default.php provides a memcached config example which will break the TYPO3 BE+FE in the following two aspects:

a) the needed but missing frontend config-aspekt leads to a broken BE + FE with the following Error:

Uncaught TYPO3 Exception Class does not exist ReflectionException thrown in file t3lib/class.t3lib_div.php in line 5250.

b) configuring memcached ONLY for cache_pages (and not also for cache_hash and cache_pagesection will break the TYPO3 BE+FE
with the following Error:

#1: PHP Catchable Fatal Error: Argument 4 passed to t3lib_cache_Factory::create() must be an array, null given, called in /t3lib/class.t3lib_cache.php on line 67 and defined in /t3lib/cache/class.t3lib_cache_factory.php line 72 t3lib_error_Exception thrown in file /t3lib/error/class.t3lib_error_errorhandler.php in line 106.

Solution: Update the comment in line 149-160 to the below (or move it into any meaningnful documentation and add a link thereupon).

/*
For memcached, use: =============
$TYPO3_CONF_VARS['SYS']['caching']['cacheConfigurations'] = array (
'cache_hash' => array(
'frontend' => 't3lib_cache_frontend_VariableFrontend',
'backend' => 't3lib_cache_backend_MemcachedBackend',
'options' => array(
'servers' => array('localhost:11211'),
)
),
'cache_pages' => array(
'frontend' => 't3lib_cache_frontend_VariableFrontend',
'backend' => 't3lib_cache_backend_MemcachedBackend',
'options' => array(
'servers' => array('localhost:11211'),
)
),
'cache_pagesection' => array(
'frontend' => 't3lib_cache_frontend_VariableFrontend',
'backend' => 't3lib_cache_backend_MemcachedBackend',
'options' => array(
'servers' => array('localhost:11211'),
)
),
); =============
You need to have memcached installed as a daemon and also as a PHP extension!
*/

(issue imported from #M16128)


Related issues

Duplicates TYPO3 Core - Bug #23694: [Caching framework] Improve error message if no frontend was defined for core caches Closed 2010-10-08

History

#2 Updated by Christian Kuhn over 8 years ago

Resolved as duplicate of #23694

The misleading configuration example was removed with #23694

#3 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF