Bug #23887

In t3lib_BEfunc::viewOnClick, parameter $altUrl doesn't ignore all other parameters

Added by Mikkel Ricky over 8 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-10-31
Due date:
% Done:

0%

TYPO3 Version:
4.4
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The method documentation for t3lib_BEfunc::viewOnClick states that

  • @param string $altUrl is an alternative URL which - if set - will make all other parameters ignored: The function will just return the window.open command wrapped around this URL!

This is, however, not the case and it hasn't been since Rev. 4482.

Issue 0011468 addresses this, but the resolution doesn't make using $altUrl work as documented as ($altUrl is used as part of the computed view url).

Solution: use $altUrl as (complete) view url if set. Otherwise compute view url based on other parameters.

(issue imported from #M16188)

patch_16188.diff View (3.87 KB) Administrator Admin, 2010-10-31 17:10

History

#1 Updated by Alexander Opitz over 5 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (4.5 or 6.1)?

#2 Updated by Alexander Opitz about 5 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this ticket.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF