Bug #24007

Workspace Draft Records are shown in Live Workspace in some cases

Added by Joerg Kienast about 9 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-11-10
Due date:
% Done:

0%

TYPO3 Version:
4.4
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you create a new record in a draft workspace and don't swap or publish it, it is shown in the live workspace as well.

This problem only occurs in some rare cases if you use a Extbase extension which works with setRespectStoragePage(false) or if you make use enableFields in your SQL query in the frontend to fetch records and you don't use a PID check.

This happens because the class.t3lib_page.php doesn't filter out records with the pid -1

Patch adds the check for the pid != -1 to filter out these records
(issue imported from #M16335)

ws_pid.patch View (640 Bytes) Administrator Admin, 2010-11-10 17:34

History

#1 Updated by Steffen Gebert about 9 years ago

committed to
- trunk rev. 9328
- 4-4 rev. 9329

Thanks for your contribution, Joerg!

#2 Updated by Ernesto Baschny over 6 years ago

  • Target version deleted (1088)

#3 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF