Bug #24017

htmlArea RTE: PHP Warning: Invalid argument supplied for foreach() in ext_tables.php, line 28

Added by Fabrizio Branca about 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-11-11
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem:
The foreach loop in EXT:rtehtmlarea/ext_tables.php creates warnings because it is not always an array.

Solution:
Check if $TYPO3_CONF_VARS['EXTCONF'][$_EXTKEY]['plugins'] is an array before

(issue imported from #M16347)

16347.patch View (925 Bytes) Administrator Admin, 2010-11-11 08:17

rtehtmlarea_bugfix_16347_trunk.patch View (3.04 KB) Administrator Admin, 2010-11-12 17:05


Related issues

Related to TYPO3 Core - Feature #23968: htmlArea RTE: Add context sensitive help to remove format dialogue Closed 2010-11-06

History

#1 Updated by Stanislas Rolland about 9 years ago

Hi Fabrizio,

Thanks for caring about this issue.

However, I had to change the referenced array to ensure that the extension's csh files are always available.

Regards,
Stanislas

#2 Updated by Stanislas Rolland about 9 years ago

Committed to SVN TYPO3core trunk (revision 9345).

#3 Updated by Susanne Moog almost 9 years ago

  • Target version deleted (4.5.0)

Also available in: Atom PDF