Bug #24056

innerWrap2 only working if innerWrap exists

Added by Tim Klein-Hitpaß about 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-11-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In the 4.4.4 Version following TS code did work (rendered a correct content) in all cases:

stdWrap {
wrap = |

innerWrap = <span>|</span>        
innerWrap.if {
isTrue.field = tx_pagesettings_offerimage
negate = 1
}
innerWrap2 = <span>|</span>
innerWrap2.dataWrap = <img src="{field:tx_pagesettings_offerimage}" alt="" />|
innerWrap2.if {
isFalse.field = tx_aldpagesettings_offerimage
negate = 1
}
}

When testing with 4.5.0-alpha3 the innerWrap2 was not rendered in the output.
I tried several ways to get it work again and it seams that innerWrap2 only "works" when a innerWrap is rendered. after changing the TS to:

stdWrap {
wrap = |

innerWrap = <span>|</span>
innerWrap2 = |
innerWrap2.dataWrap = <img src="{field:tx_aldpagesettings_offerimage}" alt="" />|
innerWrap2.if {
isFalse.field = tx_pagesettings_offerimage
negate = 1
}
}

the innerWrap2 was rendered again.
I think the always defined innerWrap in the second TS-code is the reason for the correct rendering of innerWrap2.

I did not try Version 4.5.0-alpha1 or 4.5.0-alpha2.
(issue imported from #M16391)


Related issues

Is duplicate of TYPO3 Core - Bug #23826: stdWrap "insertData" does not work anymore if using "override" additionallyClosed2010-10-22

Actions
#1

Updated by Jo Hasenau about 10 years ago

Well - it seems you are on the wrong track. ;-)

The real problem can be found at #16110 and is fixed in current trunk.

#2

Updated by Ernesto Baschny about 10 years ago

Fixed already with #16110 in 4.5 beta1. Thanks!

#3

Updated by Susanne Moog almost 10 years ago

  • Target version deleted (4.5.0)

Also available in: Atom PDF