Bug #24136

Live-Search uses hardcoded texts

Added by Felix Kopp over 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2010-11-19
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The labels within the livesearch fly-out are not internationalized but hardcoded within $helpContent (class.extdirect_dataprovider_backendlivesearch):

These texts are
- "How to use advanced search tags" and
- "Search in certain tables: page:Home will search for all pages with the title "Home""

Put labels into 'LANG'
(issue imported from #M16481)

16841.diff View (2.21 KB) Administrator Admin, 2010-12-27 16:47


Related issues

Related to TYPO3 Core - Feature #24092: Add live search to the backend toolbar Closed 2010-11-17

History

#1 Updated by Chris topher about 9 years ago

These texts are also present in locallang_misc.xml. I just translated them and I now see them in German.
Maybe these texts in the PHP file are not needed at all and can be removed?

But there is one other untranslated text:
- The word "Search" when you hover over the magnifier icon, coming from typo3/classes/class.livesearch.php line 73.

And something else:
- A tooltip is missing when you hover over the "x" which empties the search field.

#2 Updated by Jeff Segars about 9 years ago

Thanks for the bug report! You're right that the hardcoded strings in the PHP files are not used at all. Attached patch removes this code and fixes the hardcoded title attribute of "Search".

For the time being, I don't think we need a tooltip over the "x" since this is used throughout the core without a tooltip.

#3 Updated by Jeff Segars about 9 years ago

Committed to trunk in r9909.

#4 Updated by Susanne Moog almost 9 years ago

  • Target version deleted (4.5.0)

Also available in: Atom PDF