Bug #24287

content is always placed in "normal" column if BE user doesn't have permissions for the "page content - column" field

Added by Christian Boltz about 10 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-12-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I'm using 4.5 beta2 introduction package. When I login as "simple editor" add add a content element to the left column, it is placed in the "normal" (content) column. (I didn't test the right and border column, but I expect the same problem there.)

Workaround: give the user permissions to the "page content - column" field.
(Needless to say that I don't really like this - it adds a more or less useless field to the user interface, and there's a reason why it is called "simple editor" ;-)

The "column" setting should be honored when creating a new content element, even if the user doesn't have access to that field.

- login as simple editor (as defined in the introduction package)
- add a content element to the left column
- save and close
- check where it is placed - it will be in the "normal" column, not in the left column

(issue imported from #M16673)

#1

Updated by Alexander Opitz about 7 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • TYPO3 Version set to 4.5
  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (4.5 or 6.1)?

#2

Updated by Alexander Opitz almost 7 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this ticket.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF