Bug #24334

sendCacheHeaders: Wrong usage of Pragma: public and no-cache

Added by Georg K├╝hnberger almost 9 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Category:
Caching
Target version:
-
Start date:
2010-12-13
Due date:
% Done:

0%

TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem:
Given chache-headers are turned on via config.sendCacheHeaders = 1
class.tslib_fe.php outputs "Pragma: public" which is plain wrong.
Additionally class.tslib_fe.php outputs "Pragma: no-cache" which is depricated since HTTP/1.1.

- "Pragma: public" as http-header-response, never existed in HTTP/1.0 and neighter in HTTP/1.1, as public is implicit, thus should be removed.

- "Pragma: no-cache" is deprecated in HTTP/1.1 and should also be removed, since "Cache-Control: no-cache ..." is returned anyway and correct.

Solution:
- remove "Pragma: public"
- remove "Pragma: no-cache"

Patchfile is attached

INFO:
RFC Hypertext Transfer Protocol -- HTTP/1.0
http://www.ietf.org/rfc/rfc1945.txt

Hypertext Transfer Protocol -- HTTP/1.1
http://www.ietf.org/rfc/rfc2616.txt

(issue imported from #M16737)

class.tslib_fe.php_444.diff View (959 Bytes) Administrator Admin, 2010-12-13 19:59

History

#1 Updated by Steffen Gebert almost 9 years ago

RFC dropped because of negative voting in core list, not a bug.

See discussion: http://lists.typo3.org/pipermail/typo3-team-core/2010-December/046939.html

#2 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF