Bug #24416

Sorting order of newly created child elements on workspaces is wrong

Added by Oliver Hader almost 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2010-12-26
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Imagine the following scenario:
  • IRRE field at a page record
  • add new child records in workspace mode

The sorting order of the records is stored incorrectly and will also be mixed up on publishing these new records. The reason for that is, that the sorting order of the placeholder records (which are created for new workspaces elements as a "live pendant") is not updated.

(issue imported from #M16846)

0016846.patch View (3.33 KB) Administrator Admin, 2010-12-26 18:45

0016846_44.patch View (3.33 KB) Administrator Admin, 2010-12-26 19:21

16846_followup.patch View (1.35 KB) Administrator Admin, 2011-01-01 20:12

History

#1 Updated by Oliver Hader almost 9 years ago

Committed to SVN Trunk (rev. 9950)

#2 Updated by Oliver Hader almost 9 years ago

Committed follow-up to SVN Trunk (rev. 9979)

#3 Updated by Susanne Moog over 8 years ago

  • Target version deleted (4.5.0)

Also available in: Atom PDF