Bug #24452

tcaTree in flexforms still breaks

Added by Georg Ringer about 10 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
Start date:
2011-01-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Using the tcatree in flexforms shows some strange debug code because of a missing htmlspecialchars.
Problem is that "value="' . $row[$field] . '" />" breaks the whole layout as $row[$field] holds the complete xml structure (t3lib_TCEforms_Tree -> renderField())

Simple solution: Use a htmlspecialchars to fix the layout breaking but I don't know if this is a real solution.

My flexform setting is:
------------
<settings.category>
<TCEforms>
<label>LLL:EXT:news2/Resources/Private/Language/locallang_be.xml:flexforms_general.category</label>
<config>
<type>select</type>
<renderMode>tree</renderMode>
<treeConfig>
<parentField>parentcategory</parentField>
<appearance>
<expandAll>TRUE</expandAll>
<showHeader>TRUE</showHeader>
</appearance>
</treeConfig>
<MM>tx_news2_domain_model_news_category_mm</MM>
<foreign_table>tx_news2_domain_model_category</foreign_table>
<foreign_table_where> AND (tx_news2_domain_model_category.sys_language_uid = 0 OR tx_news2_domain_model_category.l10n_parent = 0)</foreign_table_where>
<size>10</size>
<autoSizeMax>20</autoSizeMax>
<minitems>0</minitems>
<maxitems>20</maxitems>
</config>
</TCEforms>
</settings.category>
------------
(issue imported from #M16890)


Files

tcatree-flex.gif (8.19 KB) tcatree-flex.gif Administrator Admin, 2011-01-02 12:43
16890-tcatree.patch (1.19 KB) 16890-tcatree.patch Administrator Admin, 2011-01-26 16:31
16890-flexforms_v2.patch (1.16 KB) 16890-flexforms_v2.patch Administrator Admin, 2011-02-02 08:12

Related issues

Related to TYPO3 Core - Feature #24131: tcaTree should work in flexforms tooClosedSteffen Ritter2010-11-18

Actions
#1

Updated by Georg Ringer about 10 years ago

further more it doesn't seem that the values are correctly saved

#2

Updated by Steffen Kamper about 10 years ago

Georg, could you attach a demo extension?

#3

Updated by Georg Ringer about 10 years ago

check out https://svn.typo3.org/TYPO3v4/Extensions/news2/trunk/ and change the settings in flexforms (Configuration/FlexForms/flexform_news.xml) to the settings above under (additional information) because I didn't check in that code yet

#4

Updated by Georg Ringer about 10 years ago

i checked in the code in news2

#5

Updated by Steffen Kamper about 10 years ago

Hi Georg,

This isn't easy to solve as tcemain doesn't resolve flexform fields automatic.
Nothing to get fixed now for RC1, hopefully for final. Would be glad if you could do some pre-debugs to find the real problem. (SteffenR is sitting in the caribic :p)

vg Steffen

#6

Updated by Georg Ringer about 10 years ago

i can look at it next week

#7

Updated by Georg Ringer about 10 years ago

trunk: rev. 10462, 4-5: rev 10461

Also available in: Atom PDF