Bug #24744

Resizable textares not working in Chrome 9

Added by Andreas Becker (Andi) almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
Start date:
2011-01-23
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Typoscript Editor allows only to enter one character and than blocks until you click again with the mouse twice in the Editor where you want to edit, enter or delete the next letter.

We are using Chrome 9.0.597.67 beta on Ubuntu 10.10, TYPO3 4.5.0rc1, Framework for TemplaVoila, Debian 5 Server.
(issue imported from #M17235)


Related issues

Related to TYPO3 Core - Bug #23644: Improve the look of admin panel Closed 2010-09-29
Related to TYPO3 Core - Bug #24802: Admin Panel CSS is loaded in the Backend Closed 2011-01-25

History

#1 Updated by Steffen Gebert almost 9 years ago

Can't reproduce, works for me with Chrome 9 on MacOS

#2 Updated by Steffen Gebert almost 9 years ago

Ah, indeed! I just encountered this issue. I thought you're talking of t3editor.

It's the resizable textarea TypoScript config in the page properties. You can type exactly one character, then nothing happens anymore.

Works in FF, breaks in Chrome9

#3 Updated by Steffen Gebert almost 9 years ago

Andreas, do you have some minutes to figure out, in what revision this problem was introduced? Or is it a general incompatibility with chrome 9 and also happens in TYPO3 4.4?

#4 Updated by Steffen Gebert almost 9 years ago

Okay, the resizable textareas don't work in Chrome 9.

In Chrome 8 they worked, also in TYPO3 4.4.

As Chrome 9 is still beta, I would not treat this as a blocker for 4.5 final, however it should be fixed soon.

#5 Updated by Steffen Gebert almost 9 years ago

Chrome 9 users can disable the resizable text areas for first aid..

#6 Updated by Andreas Becker (Andi) almost 9 years ago

Hi Steffen, I am going here actually:

WEB - Template - Choose a Page - Info modify - Edit the whole template record - Go to Constant or Setup - or description (while in description you can write AND afterwards delete one letter, delete direct afterwards is not possible in Constants and Setup)

in beta2 it is still working, so it came in beta3

#7 Updated by Steffen Gebert almost 9 years ago

Sounds hilarious, but this bug is caused by adding the CSS file admin_panel.css in #23644 (rev 9924).

Although none of the definitions matches any of the TCEforms elements (I think), it has this weird side-effect of making the textareas unusable.

#8 Updated by Steffen Gebert almost 9 years ago

This is my comment to #23644:

It really sounds hilarious, but this patch makes the resizable textareas in the backend unusable (*) in Chrome 9 (works in Chrome 8).
To be more specific: Adding the file admin_panel.css

I don't know how and why.. yes.. but it is how it is.

All definitions look well prefixed with #TSFE_ADMIN_PANEL_FORM, CSS validator and my two validator eyes also couldn't find any obvious issue.

So one question, which could remedy this problem: Has this file to be loaded in the backend? I don't think so, as it's loaded in lass.tslib_adminpanel.php. However, placing it in EXT:t3skin/stylesheets/(visual|structure)/ automatically causes it to be loaded in backend.

Could this file just be moved to t3skin/stylesheets/adminpanel/ or similar? This should fix the issue.

#9 Updated by Jeff Segars almost 9 years ago

Fix is in #24802 and is pending on the core list. Any votes would be appreciated! Thanks!

#10 Updated by Steffen Gebert almost 9 years ago

Fixed by #24802

Also available in: Atom PDF