Feature #24901

Idea about faster loading modules

Added by Kay Strobach over 11 years ago. Updated almost 11 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-01-31
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

Hello guys,

using 4.5 since trunk now i do have a suggestion how to speed up module loading in backend rapidly ;) (It's still fast - but can be even more faster)

Step 1:
Use an ExtJS CardLayout for the right Module Frame.

Step 2:
Old modules get an iframe (eventually only one) in that CardLayout(Like Tabs but without userselectable card - needs to be selected via activeCard setting).
New Modules get an ExtPanel.

Step 3:
Event about changed env:
- module activated
- module deactivated
- pageselected
- ...

Using that the new modules like extmgm, trash, EXT:ks_sitemgr and others get the change to transfer only changed parts (grid stores, etc.) and thus it makes UI faster.

What do you think about that?

Regards
Kay

(issue imported from #M17416)


Related issues

Is duplicate of TYPO3 Core - Feature #12664: Idea about faster loading modulesClosedKay Strobach2011-01-31

Actions
#2

Updated by Thorsten Kahler almost 11 years ago

  • Status changed from New to Rejected
  • Target version deleted (0)
  • TYPO3 Version set to 4.6

This feature request is handled in #12664 (and already closed there).

Also available in: Atom PDF