Bug #25002

FIRST_INSTALL has no effect when typo3conf is not writable

Added by Peter Beernink about 9 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2011-02-11
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In r8023 the FIRST_INSTALL file has been introduced which allows for easier install by creating the ENABLE_INSTALL_TOOL the first time.
However, when the typo3conf directory is not writable, this fails silently, causing the user to see the message no ENABLE_INSTALL_TOOL is found.

Solution: Add check if the typo3conf/ directory is writable. If not, give a notice about this.

(issue imported from #M17544)

17544.diff View (4.75 KB) Administrator Admin, 2011-02-11 13:27

History

#1 Updated by Peter Beernink about 9 years ago

Added patch for this issue.

#2 Updated by Ernesto Baschny over 6 years ago

  • Category set to Install Tool
  • Target version changed from 0 to 6.2.0

I've just stumbled over this. Would be a nice usability improvement for 6.2!

#3 Updated by Ernesto Baschny over 6 years ago

  • Status changed from New to Accepted

#4 Updated by Wouter Wolters over 6 years ago

FIRST_INSTALL is not there anymore.. maybe ask Christian (lolli) what to do with it.

#5 Updated by Christian Kuhn over 6 years ago

  • Status changed from Accepted to Closed
  • Is Regression set to No

The FIRST_INSTALL concept was removed with the install tool refactoring in 6.2.

I think this issue will no longer be fixed in older version - it is open for 2 years already, there are not many comments by others, so general interest seems to be relativly low.

I'll close the issue for now.

@Peter: if this is still important for you, you could still re-open the issue and maybe push a patch for older releases to review.typo3.org if you wanna have that still fixed.

#6 Updated by Peter Beernink over 6 years ago

The problem (as far as I know) only occurred in some situations when installing the introduction package.
As the introduction package longer will be released as a separate package (if I understood correctly) this probably isn't an issue anymore.

#7 Updated by Christian no-lastname-given over 5 years ago

This Bug already exists in Typo3 CMS 6.2.4

To reproduce:

wget http://get.typo3.org/6.2
tar xvzf 6.2 
rm -f 6.2
ln -s typo3_src-6.2.4 typo3_src
ln -s typo3_src/index.php
ln -s typo3_src/typo3
touch FIRST_INSTAL

But the first intall message only disappears, if you do 1 more step

mkdir typo3conf

Also available in: Atom PDF