Bug #25287

error when using t3lib_TCEmain->clear_cacheCmd in CLI mode

Added by Daniel Schöne over 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2011-03-09
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

it should be checked that TYPO3 is not running in CLI mode before writing to log

if (!defined('TYPO3_cliMode')) {
$this->BE_USER->writelog(3, 1, 0, 0, 'User %s has cleared the cache (cacheCmd=%s)', array($this->BE_USER->user['username'], $cacheCmd));
}

related to http://bugs.typo3.org/bug_view_page.php?bug_id=16832
(issue imported from #M17900)


Related issues

Related to TYPO3 Core - Bug #28007: TCEmain::clear_cacheCmd relies on active BE_USER Closed 2011-07-08

History

#1 Updated by Klaus Hinum about 8 years ago

  • Target version deleted (0)

bug is still present with 4.6 and related to the caching framework (as we had to switch with 4.6)

#2 Updated by Steffen Gebert almost 8 years ago

Klaus, could you please provide some example code to test? I will push a patch for #28007 to fix this. These bug reports about abused TCEmain occur too often to say "don't fix".

#3 Updated by Steffen Gebert almost 8 years ago

  • Status changed from New to Closed

Closed as duplicate of #28007. Would be nice to get feedback there!

#4 Updated by Steffen Gebert almost 8 years ago

  • Assignee set to Steffen Gebert

Also available in: Atom PDF