Bug #25503

Editor does not respect charset settings while saving with AJAX

Added by Helmut Hummel over 13 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Administrator Admin
Category:
t3editor
Target version:
-
Start date:
2007-11-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I tried entering some special characters in the Editor (eg äößé), then
saving (using AJAX), then reloading the template again. Characters are
garbled. Seems like the AJAX saving function has problems with the
charset settings (currently I'm not using UTF8).

(issue imported from #M6812)


Related issues

Related to TYPO3 Core - Bug #25528: "+" (plus) signs are replaced by spacesClosedAdministrator Admin2008-04-26

Actions
#1

Updated by Helmut Hummel over 13 years ago

The normal saving is working fine. See:

http://img265.imageshack.us/img265/4564/diffgv1.gif

One is saved via AJAX, the other one the normal way (t3editor disabled)

It works, when using forceCharset = utf-8

#2

Updated by Administrator Admin over 13 years ago

with the new mochkitfree version (#0007238) it's much more worse than before:
now the complete code after the special char got cut off!

i'm working on this!

#3

Updated by Administrator Admin about 13 years ago

Prototype uses the javascript function "encodeURIComponent" for encoding the ajax-posts.
this works fine, if the document charset is UTF-8 but causes encoding problems when using e.g. ISO-8859.

This snippet fixes the problem for the editor:
if (document.characterSet != "UTF-8") {
encodeURIComponent = escape;
}

I guess this can solve similar problems in other cases, too.
So we should keep this in mind for later :-)

#4

Updated by Administrator Admin about 13 years ago

will be fixed (for the editor, not in general) in the next patch release

#5

Updated by Administrator Admin about 13 years ago

finally fixed for the editor since rc2

#6

Updated by Michael Stucki over 7 years ago

  • Project changed from 75 to TYPO3 Core
  • Target version deleted (0)
#7

Updated by Michael Stucki over 7 years ago

  • Category set to t3editor

Also available in: Atom PDF