Bug #25759

After Upgrade from 4.4 to 4.5: flooded error log with Core: Exception handler (WEB): Uncaught TYPO3 Exception: No TypoScript template found! | RuntimeException thrown in file ..../typo3/sysext/cms/tslib/class.tslib_fe.php in line 2126

Added by Markus no-lastname-given almost 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-04-05
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After upgrading from TYPO3 4.4 to 4.5 my TYPO3 error log is flooded with the following error message:

Core: Exception handler (WEB): Uncaught TYPO3 Exception: No TypoScript template found! | RuntimeException thrown in file ..../typo3/sysext/cms/tslib/class.tslib_fe.php in line 2126

What's the reason?!

History

#1 Updated by Ernesto Baschny almost 9 years ago

  • Status changed from New to Needs Feedback

Check your webserver's accesslog to see which URLs are being called that might be generating this. I guess there are URLs that google or other "bots" are trying to fetch which do not have e Template associated with it.

In the past this was not an exception (just a "die()"), so this just makes you now know there is a problem that have been there before.

Please come back here after checking that, else we'll close the issue if we can get no further feedback.

#2 Updated by Stefano Cecere almost 9 years ago

also my syslogs are fulfilled by

Core: Exception handler (WEB): Uncaught TYPO3 Exception: Reason: File "index.php" was not found (1)! | RuntimeException thrown in file /var/www/apps/typo3_src-4.5.2/typo3/sysext/cms/tslib/class.tslib_fe.php in line 1572

and

Core: Exception handler (WEB): Uncaught TYPO3 Exception: Reason: File "favicon.ico" was not found (1)! | RuntimeException thrown in file /var/www/apps/typo3_src-4.5.2/typo3/sysext/cms/tslib/class.tslib_fe.php in line 1572

i still can't find a motive.. maybe basedirs??

#3 Updated by Markus no-lastname-given almost 9 years ago

Thanks. I will check the apache log files. Wouldn't it be a good idea, that TYPO3 logs the called url in the log? This would help to find out the cause of the log file entry...

#4 Updated by Stefano Cecere almost 9 years ago

i agree.. we should log requesting url (for error messages at least9

i'm discovering more errors like:

Core: Exception handler (WEB): Uncaught TYPO3 Exception: The requested page does not exist! | RuntimeException thrown in file /var/www/apps/typo3_src-4.5.2/typo3/sysext/cms/tslib/class.tslib_fe.php in line 1030

Core: Error handler (FE): PHP Warning: file_exists(): open_basedir restriction in effect. File(../) is not within the allowed path(s): (/dev/urandom/:/var/www/apps/:/var/www/vhosts/csite/www/:/var/www/vhosts/csite/tmp/) in /var/www/apps/typo3_src-4.5.2/typo3/sysext/cms/tslib/class.tslib_content.php line 5561

Core: Exception handler (WEB): Uncaught TYPO3 Exception: The page is not configured! [type= 246][] | RuntimeException thrown in file /var/www/apps/typo3_src-4.5.2/typo3/sysext/cms/tslib/class.tslib_fe.php in line 2067

(last two could be some kind of bots/attacks)

#5 Updated by Stefa No almost 9 years ago

same situation of stefano after upgrading typo3 4.4.6 to 4.5.2.

workaround:

by now, i've stopped this message flood
by setting up a custom error page:

$TYPO3_CONF_VARS['FE']['pageNotFound_handling'] = "/page-not-found";

this way typo3 does not log exceptions for missing pages.

how long will it work? i don't know:

if it is a wanted behaviour to log not found urls,
logging should be active also with the last setting,
and it would be useful to toggle typo3-logging of these errors
(i.e. by using "die()" instead of raising exception),
through some variable in localconf.php (default=off?):

- why wasting space on db (and probably cpu time too?)
"by default", when/if you are in the condition to read
404 errors on your webserver logs?

- on an old and known site with a big traffic,
having many dead links spread around across the web,
these messages could become more noisy than useful,
and more urgent logs can get lost in the noise (thousands/day)...
yes, maybe by manually checking every souspicious pattern
into the log you could recognize and prevent some attack,
but if someone would simply avoid going crazy,
he could simply keep things up to date and maybe sometimes
hunt that patterns in the webserver error log.

however, maybe this is not a problem on small or medium sites,
neither on a big site if pageNotFound_handling is going
to keep its current behaviour: so, let us know how/if things
are going to change...

bye & thanks for your support

#6 Updated by Steffen Gebert almost 9 years ago

Btw. TYPO3 4.6 will add the REQUEST_URL to the log entry. See #25924 (rev e04e56d8).

#7 Updated by Susanne Moog over 8 years ago

  • Status changed from Needs Feedback to Closed

I'm closing this issue as this does not seem to be a TYPO3 core bug. If you still have feature wishes for the logging please report them as separate feature requests. Thanks.

Also available in: Atom PDF