Bug #27099

HMENU.excludeUidList is not accounted for when determining if a submenu is available

Added by Jeff Segars over 8 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-05-27
Due date:
% Done:

0%

TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

HMENU.excludeUidList is used to exclude certain pages from menus and is read by tslib_menu->getBannedUids(). This getBannedUids() method is called when actually generating a menu, but is not accounted for when determining menu item states such as IFSUB, ACTIFSUB, and CURIFSUB. This means that IFSUB will trigger even if a page has no visible submenu because its subpages are part of HMENU.excludeUidList.

The solution is to add a check for getBannedUids() inside tslib_menu->isSubMenu().

27099.diff View (979 Bytes) Jeff Segars, 2011-05-27 21:29

History

#1 Updated by Jeff Segars over 8 years ago

#2 Updated by Alexander Opitz over 5 years ago

  • Status changed from Accepted to Needs Feedback
  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (4.5.35 or 6.2.4)?

#3 Updated by Alexander Opitz almost 5 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Jeff Segars)

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF