Bug #27935

Exclude E_DEPRECATED form exceptional errors

Added by Helmut Hummel about 10 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Miscellaneous
Target version:
Start date:
2011-07-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem:
When an extension uses deprecated PHP functions with PHP 5.3, TYPO3 throws an exception because E_DEPRECATED is not excluded in the list of exceptional errors

Solution:
Add E_DEPRECATED to this list.

#1

Updated by Mr. Hudson about 10 years ago

Patch set 1 of change I3b5b4c8ec1738f9a3a9be146bb7e3a8a005087f3 has been pushed to the review server.
It is available at http://review.typo3.org/3088

#2

Updated by Mr. Hudson about 10 years ago

Patch set 2 of change I3b5b4c8ec1738f9a3a9be146bb7e3a8a005087f3 has been pushed to the review server.
It is available at http://review.typo3.org/3088

#3

Updated by Mr. Hudson about 10 years ago

Patch set 3 of change I3b5b4c8ec1738f9a3a9be146bb7e3a8a005087f3 has been pushed to the review server.
It is available at http://review.typo3.org/3088

#4

Updated by Anonymous about 10 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100
#5

Updated by Ernesto Baschny about 10 years ago

  • Status changed from Resolved to Under Review
  • Target version changed from 1281 to 4.5.4
  • TYPO3 Version changed from 4.6 to 4.5

I would also like to have this in 4.5, since it will be around for 3 years and some are already using it with PHP 5.3.

See https://review.typo3.org/3117

#6

Updated by Anonymous about 10 years ago

  • Status changed from Under Review to Resolved
#7

Updated by Riccardo De Contardi almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF