Bug #29234

RTE only loads TD styles from external css file on reload

Added by Ernesto Baschny about 8 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2011-08-24
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

I want to enable Table-Cell styles in RTEhtmlarea. It works great, but I have problems with IE8. Here's the setup:

TYPO3 4.5.5
PageTS:

RTE.default {
contentCSS = fileadmin/contentRTE.css
classesTD := addToList(highlight-blue)
}

fileadmin/contentRTE.css contains:

TD.highlight-blue { background-color: #003399; color: #ffffff; font-weight: bold;  }
TD.align-left { text-align: left; }
TD.align-center { text-align: center; }
TD.align-right { text-align: right; }

Now everything works as expected in FF and Chrome. In IE8, on first loading of an editing Form, I get these CSS loaded (shown in the F12 - developer tools):

The RTE displays the list of available TD classes like this. Not even "Justify Left" etc are shown!

Then I simply reload the frame where the RTE is located. The CSS list is now this:

And the RTE works as expected:

Of course I cannot tell the editor to keep reloading the editing frame before beginning, so I would love to see this fixed.

If an environment is required to reproduce, please let me know. I was able to transfer the above scenario from one very complex installation to a simple and and reduced the test-bed to simple the above shown, so it should be simple to test.

rte-table-styles-01-first-load.png View (27.7 KB) Ernesto Baschny, 2011-08-24 21:23

rte-table-styles-02-first-load-rte.png View (14.4 KB) Ernesto Baschny, 2011-08-24 21:23

rte-table-styles-03-reload.png View (22.4 KB) Ernesto Baschny, 2011-08-24 21:23

rte-table-styles-04-reload-rte.png View (13.2 KB) Ernesto Baschny, 2011-08-24 21:23

Associated revisions

Revision 7c35e485 (diff)
Added by Stanislas Rolland about 8 years ago

[BUGFIX] RTE only loads styles from external css file on reload in IE8

Problem: The script fails to detect that a stylesheet is not loaded
Solution: Check for empty rules and imports arrays of skin and
content stylesheets.

Change-Id: Ie9669ca79e7814805dc5dbcd29f5f65939524071
Resolves: #29234
Releases: 4.5, 4.6
Reviewed-on: http://review.typo3.org/4858
Reviewed-by: Stanislas Rolland
Tested-by: Stanislas Rolland

Revision e1de967d (diff)
Added by Stanislas Rolland about 8 years ago

[BUGFIX] RTE only loads styles from external css file on reload in IE8

Problem: The script fails to detect that a stylesheet is not loaded
Solution: Check for empty rules and imports arrays of skin and
content stylesheets.

Change-Id: Ia8bdac51f52f07b4028af2c8613ee8f7324a6e91
Resolves: #29234
Releases: 4.4, 4.5
Reviewed-on: http://review.typo3.org/4833
Reviewed-by: Ernesto Baschny
Tested-by: Ernesto Baschny
Reviewed-by: Stanislas Rolland
Tested-by: Stanislas Rolland

History

#1 Updated by Mr. Hudson about 8 years ago

Patch set 1 of change I3f47992f0caa85e643a58df3115240595337f012 has been pushed to the review server.
It is available at http://review.typo3.org/4580

#2 Updated by Ernesto Baschny about 8 years ago

Unfortunately the patch posted into review doesn't fix the issue for me. I still get the same effect as mentioned above.

I noticed that the "Unknown styles" only happen on first load of any RTEhtmlarea in this particular IE session. As soon I load it again (simply by closing and re-opening the same element for editing again), the style is there. Even if I logout and re-login, the style is there.

So to reproduce, you need to close all IE8 instances before logging in again and editing.

#3 Updated by Stanislas Rolland about 8 years ago

Ernesto Baschny wrote:

Unfortunately the patch posted into review doesn't fix the issue for me. I still get the same effect as mentioned above.

Did you clear the RTE cache and the browser cache after applying the patch?

I noticed that the "Unknown styles" only happen on first load of any RTEhtmlarea in this particular IE session. As soon I load it again (simply by closing and re-opening the same element for editing again), the style is there. Even if I logout and re-login, the style is there.

So to reproduce, you need to close all IE8 instances before logging in again and editing.

I think that it should be sufficient to clear the browser cache to reproduce the effect.

#4 Updated by Stanislas Rolland about 8 years ago

  • Status changed from New to Under Review
  • Target version set to 1341

I was able to reproduce this error with TYPO3 4.5. But I am unable to reproduce it after applying the change in review http://review.typo3.org/4580 and clearing the RTE cache using the BE Clear cache menu.

#5 Updated by Mr. Hudson about 8 years ago

Patch set 1 of change I4c7829c8946fdb4005ddf6e4c9876a8f74b718ea has been pushed to the review server.
It is available at http://review.typo3.org/4832

#6 Updated by Mr. Hudson about 8 years ago

Patch set 1 of change Ia8bdac51f52f07b4028af2c8613ee8f7324a6e91 has been pushed to the review server.
It is available at http://review.typo3.org/4833

#7 Updated by Mr. Hudson about 8 years ago

Patch set 1 of change Ie9669ca79e7814805dc5dbcd29f5f65939524071 has been pushed to the review server.
It is available at http://review.typo3.org/4858

#8 Updated by Stanislas Rolland about 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Ernesto Baschny over 6 years ago

  • Target version deleted (1341)

#10 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF