Project

General

Profile

Actions

Bug #30053

closed

Allow proper method override in tx_coreupdates_installsysexts

Added by Xavier Perseguers almost 13 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
Start date:
2011-09-19
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

Method tx_coreupdates_installsysexts::performUpdate() cannot be properly overriden because its signature is incomplete.

Actions #1

Updated by Xavier Perseguers almost 13 years ago

This leads to PHP notices

Actions #2

Updated by Mr. Hudson almost 13 years ago

Patch set 1 of change Iaf13c166c07d04ee194bec1543ac5ae450f1e38b has been pushed to the review server.
It is available at http://review.typo3.org/5078

Actions #3

Updated by Xavier Perseguers almost 13 years ago

  • Status changed from New to Under Review
Actions #4

Updated by Xavier Perseguers almost 13 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #5

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF