Bug #30208

Timepicker can't changed oldValue

Added by Guido S. about 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2011-09-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If i start a new recordset and will set a new "datetime" i get an Javascript error:
oldValue is undefined
date.setHours(oldValue.getHours());

If we set an default value like

'default'  => mktime(date('h'),date('i'),0,date('m'),date('d'),date('Y')),

all is okay.

The problem exist only in TYPO3 4.4.11. In TYPO3 4.5.6 it's fine.

Configuration:

'starttime' => array (
            'exclude' => 1,
            'label'   => 'LLL:EXT:lang/locallang_general.xml:LGL.starttime',
            'config'  => array (
                'type'     => 'input',
                'size'     => '8',
                'max'      => '20',
                'eval'     => 'datetime',
                'default'  => '0',
                'checkbox' => '0'
            )
        ),


Related issues

Is duplicate of TYPO3 Core - Bug #27730: Datepicker throws Javascript error in 4.4.8 (Regression!)Closed2011-06-28

Actions
#1

Updated by Jigal van Hemert about 9 years ago

  • Status changed from New to Closed

Closed as duplicate.

Also available in: Atom PDF