Project

General

Profile

Actions

Bug #27730

closed

Datepicker throws Javascript error in 4.4.8 (Regression!)

Added by Mario Rimann over 11 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2011-06-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

We just encountered a problem with date fields in TYPO3 v4.4.8 in an extension but it seems to be a TYPO3 related issue that is not limited to the extension.

Steps to reproduce:
- open up a record that has a datetime field with a datepicker (e.g. from pages table)
- click the datepicker to open the datepicker
- click a day in the datepicker

Expected behaviour:
- datepicker closes
- the chosen date is written into the datetime field

Current behaviour:
- datepicker closes
- nothing is written into the datetime field
- Firefox records the following error message: "oldValue is undefined" (in some compressed tceforms-[hash].js.[timestamp].gzip

Clearing all caches and deleting all the compressed JS files did not help.

The issue can be reproduced on several installations on version 4.4.8 but not on 4.5.x. For testing we downgraded to 4.4.7 where the error can't be reproduced. So we assume only 4.4.8 is affected.


Related issues 3 (0 open3 closed)

Is duplicate of TYPO3 Core - Bug #27939: Date wizard in tt_news backend not working after update from 4.4.7 to 4.4.8Closed2011-07-07

Actions
Is duplicate of TYPO3 Core - Bug #28179: Date Picker does not work in TYPO3 4.4.8 with Firefox 5: "oldValue is not defined"Closed2011-07-13

Actions
Has duplicate TYPO3 Core - Bug #30208: Timepicker can't changed oldValueClosed2011-09-22

Actions
Actions #1

Updated by Peter Kraume over 11 years ago

I can confirm this issue.

The console shows this JavaScript error:

Error: oldValue is undefined
Quelldatei: http://www.domain.tld/typo3temp/compressor/tceforms-e8f0c7a0b60355fc45244757c2015e24.js?1310476323
Row: 57
Actions #2

Updated by Oliver Hader over 11 years ago

  • Target version changed from 1264 to 1341
Actions #3

Updated by Alexander Opitz almost 10 years ago

  • Status changed from New to Closed

4.4 isn't supported any more and it seems to be fixed in 4.5 and newer as commented in #28179

Actions #4

Updated by Ernesto Baschny almost 10 years ago

  • Target version deleted (1341)
Actions

Also available in: Atom PDF