Bug #32938

Link to mounted shortcut page lacks &MP parameter

Added by Xavier Perseguers over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Must have
Category:
Miscellaneous
Target version:
Start date:
2012-01-03
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

There is a bug when generating links to shortcut pages over a mounted page.

Page tree to reproduce the problem:

root
  |-- [1] website
  |         |-- [2] page 1
  |         |-- [3] page 2
  |         `-- [4] page 3 (not shown in menu, mount point to [5])
  `-- [5] shared pages
            |-- [6] normal page
            `-- [7] tools (shortcut to 1st child)
                      `-- [8] page X

Generate a double menu, one for pages of [1], one dedicated to pages under mount point [4] (which is not shown in first menu)

Expected:

Menu 1

  • /index.php?id=2 -> page 1
  • /index.php?id=3 -> page 2

Menu 2

  • /index.php?id=6&MP=5-4 -> normal page
  • /index.php?id=8&MP=5-4 -> tools

This works only when current page is [6]. What is generated for Menu 2 when current page is within [1] ("website") is:

Menu 2 (BUG)

  • /index.php?id=6&MP=5-4 -> normal page
  • /index.php?id=8 -> tools

Thus when a link to a shortcut page is generated, it lacks the &MP parameter unless current page already contains the &MP parameter.


Related issues

Related to TYPO3 Core - Bug #29584: Shortcut to mountpoint results in illegal root treeRejected2011-09-09

Actions
Related to TYPO3 Core - Bug #19379: Mountpoint var ignored when a "Shortcut page" is in the rootlineClosed2008-09-26

Actions
Related to TYPO3 Core - Bug #17537: Shortcuts within mounted trees lose MP-ParameterClosed2007-08-16

Actions
#1

Updated by Xavier Perseguers over 10 years ago

  • Assignee set to Xavier Perseguers

TypoScript to generate the menus:

page = PAGE

page.10 = HMENU
page.10.wrap = <h1>Menu 1</h1> |
page.10.1 = TMENU
page.10.1 {
  wrap = <ul>|</ul>
  NO {
    wrapItemAndSub = <li>|</li>
  }
}

page.20 < page.10
page.20 {
  wrap = <h1>Menu 2</h1> |
  special = directory
  special.value = 4
}
#2

Updated by Xavier Perseguers over 10 years ago

  • Status changed from New to Accepted
#3

Updated by Gerrit Code Review over 10 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7656

#4

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/7749

#5

Updated by Xavier Perseguers over 10 years ago

  • Status changed from Under Review to Resolved
  • Target version set to 4.6.4
  • Complexity set to medium
#6

Updated by Xavier Perseguers over 10 years ago

  • Status changed from Resolved to Closed
#7

Updated by Andreas Wolf over 10 years ago

This does not apply to TYPO3 4.5, as this bug was introduced by feature #17037, which is not part of 4.5. Instead, 4.5 still has the bug that the MP parameter is lost for shortcuts in mount points (see e.g. #19379, #17537). This is also true for 4.6+, if you call the shortcut page instead of the shortcut target (which is not the default anymore because of this issue).

I will prepare an updated version of the patch for #17537 soon.

Also available in: Atom PDF