Bug #32966

Make TYPO3AJAX rendering false, null, 0, ...

Added by Daniel Siepmann almost 8 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Miscellaneous
Target version:
-
Start date:
2012-01-04
Due date:
% Done:

0%

Estimated time:
1.00 h
TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
no-brainer
Is Regression:
No
Sprint Focus:

Description

At the moment, the class can't render any of the following values:
  • "" (an empty string)
  • 0 (0 as an integer)
  • 0.0 (0 as a float)
  • "0" (0 as a string)
  • NULL
  • FALSE
  • array() (an empty array)
  • var $var; (a variable declared, but without a value in a class)

I think it's okay for some of them, but I like to be able to return something like:

{"effected_rows":0}

That's not possible at the moment, because calling:
$ajaxObj->addContent( 'effected_rows', 0);

Issn't saved, because 0 is an "empty" value and not saved.

Everything takes part at the method: http://api.typo3.org/typo3v4/current/html/class_8typo3ajax_8php_source.html#l00119

I think this is a missing "feature" or more a bug.
I hope you will fix this. It's not a big thing.

History

#1 Updated by Xavier Perseguers almost 8 years ago

  • Target version deleted (4.6.4)

#2 Updated by Alexander Opitz almost 5 years ago

  • Status changed from New to Needs Feedback
  • Is Regression set to No

Hi,

does the problem still exists within newer versions of TYPO3 CMS (6.2.9)?

#3 Updated by Alexander Opitz over 4 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF