Bug #34835

PHP Fatal Error, cannot view pages from Backend

Added by Björn Paulsen over 7 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-03-14
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I got a PHP fatal error if i want to view a page from the Backend. (Right Mouse Button -> View)


PHP Fatal error: Call to a member function includeLLFile() on a non-object in /var/www/typo3_common/typo3-4.5/typo3_src-4.5.13/typo3/sysext/cms/tslib/class.tslib_adminpanel.php on line 290, referer: https://www.domain.de/typo3/backend.php

To solve this Problem I insert following code:

class.tslib_adminpanel.php:289


public function display() {
+ if(empty($GLOBALS['LANG']))
+ $GLOBALS['LANG'] = t3lib_div::makeInstance('language');
$GLOBALS['LANG']->includeLLFile('EXT:lang/locallang_tsfe.php');
$moduleContent = '';

class.tslib_adminpanel.php:823


protected function extGetLL($key) {
$labelStr = htmlspecialchars($GLOBALS['LANG']->getLL($key)); // Label string in the default backend output charset.
// Convert to utf-8, then to entities:
if ($GLOBALS['LANG']->charSet != 'utf-8') {
+ if(!isset($GLOBALS['LANG']->csConfObj) || !is_object($GLOBALS['LANG']->csConfObj)) {
+ $GLOBALS['LANG']->csConvObj = t3lib_div::makeInstance('t3lib_cs');
+ }
$labelStr = $GLOBALS['LANG']->csConvObj->utf8_encode($labelStr,$GLOBALS['LANG']->charSet);
}
$labelStr = $GLOBALS['LANG']->csConvObj->utf8_to_entities($labelStr);
// Return the result:
return $labelStr;
}

class.t3lib_div.php:4843


$LOCAL_LANG = NULL;
if (@is_file($fileRef) && $langKey) {
+ if(!isset($csConfObj) || !is_object($csConfObj)) {
+ $csConvObj = t3lib_div::makeInstance('t3lib_cs');
+ }
// Set charset:
if ($charset) {

History

#1 Updated by Oliver Hader over 7 years ago

  • Status changed from New to Needs Feedback

I could not reproduce the bahaviour with TYPO3 4.5. Can you please give some more details, how to reproduce it (e.g. what needs to be enabled besides the admin panel)?

Besides that, the following would be interesting
  • the exact URL with parameters called in the frontend (you can remove domain information of course)
  • the debug_print_backtrace() at the beginning of the display() method in tslib_admPanel

#2 Updated by Björn Paulsen over 7 years ago

I have the Problem on 3 Servers since 4.5.11 why you can reproduce this? Do you make a right click on a page and select view? Did you use TemplaVoila?

The URL is the normal one http://www.xyz.de/index.php?id=xy on all Sites.

A Debug_print_backtrace I will give you as soon as I can

#3 Updated by Björn Paulsen about 7 years ago

also in the newst Version 4.5.19

Here the Backtrace:

#0 tslib_AdminPanel->display() called at [/var/www/typo3_common/typo3-4.5/typo3_src-4.5.19/t3lib/class.t3lib_tsfebeuserauth.php:239]
#1 t3lib_tsfeBeUserAuth->displayAdminPanel() called at [/var/www/typo3_common/typo3-4.5/typo3_src-4.5.19/typo3/sysext/cms/tslib/index_ts.php:580]
#2 require(/var/www/typo3_common/typo3-4.5/typo3_src-4.5.19/typo3/sysext/cms/tslib/index_ts.php) called at [/var/www/XXX/www/typo3_dummy/index.php:84]

#4 Updated by Alexander Opitz about 6 years ago

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (4.5 or 6.1)?

#5 Updated by Alexander Opitz almost 6 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

If you think, that this is the wrong decision, then please write to the mailing list typo3.teams.bugs with issue number and an explanation.

Also available in: Atom PDF