Bug #36452

Search String feature in List view not working

Added by Klaus Hinum about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2012-04-23
Due date:
% Done:

0%

TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The Search String feature in the List view is only working for page related items. Items from own extensions, or e.g. TemplaVoila are not found. That feature was working as far as I recall in previous versions (but its broken a few major releases now). Tested for example with 4.6 stable and 4.7 RC

History

#1 Updated by Markus Klein about 5 years ago

Hi Klaus,

it's not a bug, it's a feature.
See http://wiki.typo3.org/TYPO3_4.6.0#Live_Search

TCA of extensions has to be updated accordingly.

#2 Updated by Klaus Hinum about 5 years ago

Hi Markus,

thanks, you are right, somehow missed that change in 4.6.
added
'searchFields' => 'field1,field2,field3' to the ext_tables.php TCA 'ctrl' section, now it works.
E.g. for all that stumble across that

$TCA["tablename"] = array (
"ctrl" => array (
'searchFields' => 'field1,field2,field3',
)
);

#3 Updated by Steffen Ritter about 5 years ago

  • Status changed from New to Closed

Not a core problem

Also available in: Atom PDF