Feature #38255

Post processors should be extendable

Added by Soren Malling about 5 years ago. Updated almost 5 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2012-06-21
Due date:
% Done:

0%

PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

It should be possible to extend postprocessor and add configuration

At this moment the postprocessors are hardcoded to only support "mail" where as postprocessors for stuff like persisting would make the FORM tool great for user registration etc.


Related issues

Duplicates Core - Feature #32701: Enable customer postProcessors in different folder Resolved 2011-12-19

History

#1 Updated by Ulrich no-lastname-given almost 5 years ago

Soren Malling wrote:

It should be possible to extend postprocessor and add configuration

At this moment the postprocessors are hardcoded to only support "mail" where as postprocessors for stuff like persisting would make the FORM tool great for user registration etc.

Can't you do that already?

If you do (in your form typoscript):

postProcessor {
    1 = someclevername
    1 {
        thingy = with a value
    }
}

It will look for a class named tx_form_System_Postprocessor_Someclevername. Then you create that class and let it extend tx_form_System_Postprocessor_Mail or just do you own stuff.

#2 Updated by Susanne Moog almost 5 years ago

  • Status changed from New to Rejected

This ticket is a duplicate of #32701 which was fixed by https://review.typo3.org/#/c/9006/

For the sake of completeness:

Before the patch the class had to be named tx_form_System_Postprocessor_Someclevername and - for the autoloader to find it - had to be in the form extension or defined by an ext_autoload. Which is pretty ugly as form is core and you should not need to change core directories and your class should reflect your own directory structure. Now there is an interface and you can call any postprocessor that implements the interface by class name.

Also available in: Atom PDF