Bug #39271

Accessibility label translation

Added by Philippe over 8 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2012-07-25
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In the link popup, when selecting "external-link-new-window" (or another
style), the link title message is using the backend language instend of
content language.

In the page TSConfig I have "RTE.default.defaultContentLanguage = fr". I
also installed static_info_tables.

The problem exist for all languages except english (default).
I tried french as default and german as secondary, the bug exist for
both.
For english default or secondary everything work.

The problem come from the new languageDependencies variable in the TYPO3
language class. The RTE temporarily changes the backend language with
this line :

$GLOBALS['LANG']->lang = $this->contentTypo3Language;

But language class internals uses $this->languageDependencies instend of
$this->lang. Since languageDependencies is protected, it can only be set
by the lang->init() function. Also, we can't call the init() function
more than one time because it adds languages instead of replacing them.

As a temporary fix, we intanciated a local "language" object for the
content language.
(in class.tx_rtehtmlarea_browse_links.php) :

public function getLLContent($string) {
  $tempLL = t3lib_div::makeInstance('language');
  $tempLL->init($this->contentTypo3Language);
  $LLString = $tempLL->sL($string);

  return $LLString;
}

#1

Updated by Stanislas Rolland over 8 years ago

  • Status changed from New to Accepted
  • Assignee set to Stanislas Rolland
  • Target version set to 4.7.5
#2

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/15650

#3

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/15659

#4

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/15660

#5

Updated by Stanislas Rolland over 8 years ago

  • Target version changed from 4.7.5 to 4.6.13
#6

Updated by Stanislas Rolland over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#7

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF