Bug #39727

Bug #36744: Workspaces are unusable on larger installations

Calculating percentage of differences is slow

Added by Oliver Hader about 7 years ago. Updated almost 6 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
Category:
Workspaces
Target version:
Start date:
2012-08-12
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The workspace view in the backend has a feature to calculate the percentage of differences between live and workspace version.
This implementation iterates over each record and each field by using the PHP method similar_text().
The complexity of similar_text() is measured with O(n^3) which quickly can turn into a nice waiting period if string length is more than approx 4000 characters.

Changes:
  • use a different approach if string length is more than 2048 or 4096 characters
  • remove MD5 sums on files which also can turn out in a nice waiting period
  • do not resolve fields that hold m:n relations to reduce tree complexity and database queries

Maybe disable this feature in newer versions at all or us a simple MD5 based comparison of the field contents which reads then "n% of the all fields have been modified".


Related issues

Related to TYPO3 Core - Bug #39731: Calculate percentage of differences if column is shown Closed 2012-08-12
Related to TYPO3 Core - Bug #35172: Connection timeout when parsing large number of changed records Closed 2012-03-23

History

#1 Updated by Oliver Hader about 7 years ago

  • Target version set to 6.0.0-pre-beta1

#2 Updated by Oliver Hader about 7 years ago

  • Status changed from New to Rejected

Due to issue #35172 - the feature already was kicked in TYPO3 6.0

#3 Updated by Oliver Hader about 7 years ago

  • % Done changed from 0 to 100

#4 Updated by Michael Stucki almost 6 years ago

  • Category set to Workspaces

Also available in: Atom PDF